Автоматическая нумерация страниц документации в Excel

excel   638  

В процессе работы возникает необходимость часами напролет, если много данных, вручную заполнять нумерацию, например реестра документации, в Excel

Необходимо считать в уме, либо на калькуляторе, высчитывать, а если еще это делать в спешке то есть большая вероятность, что можно накосячить.

Давайте раз и навсегда исправим эту рутину.

В Excel'е есть много функций помогающих упроситить заполнение строк и столбцов, мы ими и воспользуемся. 

Перейдем сразу к делу.

 

Формула для автоматической нумерации страниц документации (напр. реестр документов):

=ЕСЛИ(E20>1;ЕСЛИ(СЧЁТ(ПОИСК("-";F19))>0;ПРАВСИМВ(F19;ДЛСТР(F19)-ПОИСК("-";F19;ПОИСК("-";F19)))+1&"-"&ПРАВСИМВ(F19;ДЛСТР(F19)-ПОИСК("-";F19;ПОИСК("-";F19)))+1+E20-1;(F19+1)&"-"&(F19+E20));ЕСЛИ(СЧЁТ(ПОИСК("-";F19))>0;ПРАВСИМВ(F19;ДЛСТР(F19)-ПОИСК("-";F19;ПОИСК("-";F19)))+1;F19+1))

 

В данном примере столбец Е отвечает за количество листов. Листов может быть 1 а может и 5 и т.д., столбец F содержит информацию сколько страниц по списку.

 

Если страниц 2 и больше, то обычно нумерация выглядит как 2-3.

 

В примере спискок документов начинает с 20 строки, поэтому в функции все начинается с ячейки E20.

F19 - это ячейка вышестоящая в столбце "Страниц по списку".

Итак, у нас есть документ, в котором мы должны сделать нумерацию документов по списку.

Мы вставляем вышеприведенную строку в соответствующие ячейки, меняем ячейки E20 и F19 на соответствующие ячейки в вашем документе, нажимаем Enter и просто протягиваем вниз.

Если у нас список начинается с 1 или в списке есть ячейки без количества, то первый документ должен иметь первый порядковый номер.

Например, у нас есть один список разделенный насколькими пустыми строками, названием разделов (см. фото ниже).

В первой ячейке мы должны поставить 1.

В начале другого раздела мы должны поставить вручную следующую цифру по списку.

Правда это не избавило от проставления цифр полностью, но нет необходимости выверять огромные списки.

Вот и вся рутина. Радуемся.

 

Вот еще пример работы с формулой:

У вас два столбца "А" и "В". В столбце "А" у вас количество листов, в "В" - страниц по списку. Список начинается со 2 строки.

Тогда функция примет вид:

=ЕСЛИ(A2>1;ЕСЛИ(СЧЁТ(ПОИСК("-";B1))>0;ПРАВСИМВ(B1;ДЛСТР(B1)-ПОИСК("-";B1;ПОИСК("-";B1)))+1&"-"&ПРАВСИМВ(B1;ДЛСТР(B1)-ПОИСК("-";B1;ПОИСК("-";B1)))+1+A2-1;(B1+1)&"-"&(B1+A2));ЕСЛИ(СЧЁТ(ПОИСК("-";B1))>0;ПРАВСИМВ(B1;ДЛСТР(B1)-ПОИСК("-";B1;ПОИСК("-";B1)))+1;B1+1))

Скачать пример



Еще из категории Программы

 

Комментарии ВК

Поиск

Метки


Голосуем
Какие темы вам больше всего интересны на сайте?

результаты